Error when running trifinger_runner/run_simulation.py

There is an error when we try to run the trifinger_runner/run_simulation.py
please tell me what to do
error message:

(trifinger_simulation) jaylon42@jaylon42-System-Product-Name:~/TRI/trifingerpro_runner-master$ ./run_simulation.py --output-dir ~/TRI/output --repository ~/rrc_2021_ws/src/three_wolves/.git  --backend-image ~/rrc_2021_ws/singularity/rrc2021_latest.sif --user-image ~/rrc_2021_ws/rrc_20210705.sif --task MOVE_CUBE_ON_TRAJECTORY
[INFO] [1625567656.787645927] [trifinger_launcher]: Starting...
pybullet build time: Dec 23 2020 01:48:06
[INFO] [1625567659.235407560] [trifinger_launcher]: Goal: [[0, [0.0016646007458253472, 0.06328055693867216, 0.07885056195124848]], [30000, [0.014842812655227352, 0.030117669736045214, 0.0447064198305218]], [40000, [-0.1283643081527872, -0.008551442410241748, 0.062104918432283274]], [50000, [-0.07287020838011725, -0.058687144778223094, 0.06379863481317732]], [60000, [0.033931798793700764, -0.07644828798762981, 0.07225838480819607]], [70000, [-0.10698457740778809, -0.04633802817244993, 0.06504004125877039]], [80000, [0.035960636012476836, 0.07747350742955812, 0.04956689122299092]], [90000, [0.05342924249778081, -0.09554854305259515, 0.05761143327055794]], [100000, [0.0655790563947213, 0.08097690686047135, 0.07234488021751231]], [110000, [0.012007102296968497, 0.0364532961541805, 0.0797595582844488]]]
[INFO] [1625567661.021136454] [trifinger_launcher]: Start data node
[INFO] [1625567661.024705758] [trifinger_launcher]: Data node is ready
[INFO] [1625567661.029081754] [trifinger_launcher]: Data node is ready
[INFO] [1625567661.030381089] [trifinger_launcher]: Data node is ready
[INFO] [1625567661.031424087] [trifinger_launcher]: Data node is ready
WARNING: passwd file doesn't exist in container, not updating
WARNING: group file doesn't exist in container, not updating
FATAL:   container creation failed: mount /usr/local/var/singularity/mnt/session/dev->/dev error: while mounting /usr/local/var/singularity/mnt/session/dev: destination /dev doesn't exist in container
WARNING: skipping mount of /etc/trifingerpro: stat /etc/trifingerpro: no such file or directory
FATAL:   container creation failed: mount /etc/trifingerpro->/etc/trifingerpro error: while mounting /etc/trifingerpro: mount source /etc/trifingerpro doesn't exist
CRITICAL:root:FAILURE: <class 'trifingerpro_runner.backend_runner.SimulationBackendRunner'>
Traceback (most recent call last):
  File "/home/jaylon42/TRI/trifingerpro_runner-master/trifingerpro_runner/run_submission.py", line 524, in run
    node.run(config, ws_dir, backend_type)
  File "/home/jaylon42/TRI/trifingerpro_runner-master/trifingerpro_runner/run_submission.py", line 456, in run
    self._wait_until_node_is_ready(
  File "/home/jaylon42/TRI/trifingerpro_runner-master/trifingerpro_runner/run_submission.py", line 245, in _wait_until_node_is_ready
    raise NodeUnexpectedTerminationError(str(type(runner)))
trifingerpro_runner.run_submission.NodeUnexpectedTerminationError: <class 'trifingerpro_runner.backend_runner.SimulationBackendRunner'>

We could reproduce the error, and we are looking into it

Hopefully, this will fix the issues:

  • We updated the master branch of the repository trifinger_runner, please pull it or reclone it
  • On your machine, please create the folder /etc/trifingerpro

Thanks for letting us know if things work out

It worked perfectly! The new version of trifinger_runner solved my previous problem.
Thanks for your help!

And a little tip for anyone like us who needs to load pre-trained model:
use [–user-data-dir USER_DATA_DIR]
the model is located at ‘…/…/userhome/XXX.zip’ (if your model is saved in USER_DATA_DIR/XXX.zip)

Hi RRC
Today when I run submit on Job Submission System, I couldn’t find my trained model(a zip file) in that system. In the [Locally Run Your Code in Simulation] I can use [–user-data-dir USER_DATA_DIR] to upload my file. I tried to upload my zip file on google drive and wget XXX.zip in python script, doesn’t work well.
Can you please tell me how to upload files in the Job Submission System?

Hi,

You can upload files to your home via:

scp /local/path/to/file USERNAME@robots.real-robot-challenge.com:

When your job is running, your home is mounted on “/userhome”

Problem solved, thx!

@vincent.berenz, after performing the steps mentioned, I see the script running and then closing down. I inspected the user_stderr.txt and I see that it says

Package 'rrc_example_package' not found

The script is use is as follows:

./run_simulation.py --output-dir ~/output \
                    --repository path/to/repo/.git \
                    --backend-image path/to/rrc2021_latest.sif \
                    --task MOVE_CUBE_ON_TRAJECTORY \
		    --sim-visualize

Any suggestions here?

Ok, this problem was solved, I had a different package name in my package.xml :laughing: